FJ1001 - The JBL Install

Questions and answers about installing Insane Audio's FJ1001
Post Reply
jimmy-buffett
Posts: 3
Joined: Wed Mar 09, 2016 8:56 pm

FJ1001 - The JBL Install

Post by jimmy-buffett » Wed Mar 09, 2016 9:36 pm

Excited to be here! I'm a new owner of an FJ1001, in my 2011 FJ Cruiser. For those of you from the FJ Cruiser Forums, I'm the same jimmy-buffett from over there. I do a lot of offroading in Colorado, and I have a software development background. The combination of those two things has led me to use my Android phone extensively to track my trail rides and take a lot of offroading photos. Trying to keep the phone charged and keep it in a position where it can receive a GPS signal, while managing trail recordings has become a pretty big hassle for me on the trails. So when I saw an offroad-oriented Android-powered head unit, I realized the potential of this product to solve several of my problems.

The reason I'm posting in Installation Tech Q&A rather than the normal section is that my 2011 FJ Cruiser has the upgraded JBL factory stereo, with subwoofer. I've been working with Kevin @ Toytec Lifts on verifying compatability with the JBL setup, we're currently on our second attempt to get the FJ10001 working.

After receiving two new test wiring harnesses from Insane Audio today, we installed the unit. Of the 5 plugs on the back of my JBL head unit, only 2 are supported by the wiring harness that I'm currently using. Amazingly, the radio is almost fully functional from just those two plugs.

Here's what is currently working:

All speakers + subwoofer
Bluetooth audio streaming + hands-free calling (not sure if the FJ's microphone or the head unit one is being used, but calls sound fine)
Factory Aux-In
Steering wheel controls, except for the verbal command button (which is a mapping issue, the head unit sees it but I'm not sure what to map it to)
Balance Right/Left control

What isn't working:

Fade control (100% back speakers = no sound, rear speakers currently driven at the level of the front speakers)
Factory USB
Factory Satellite Receiver (blue plug?)
What are those other two unused plugs in the FJ for? :lol:

I don't use the factory USB except to charge, and I don't stream satellite audio, so I'm not impacted by those two limitations. I'm waiting to see what the IA guys will do for supporting the factory USB plug before I hack it to use one of their USB plugs on the back of the unit. The fade control problem is a strange one, I'm not sure if the problem is in the wiring harness -- all speakers on the same front circuit -- or in the head unit. I'm going to guess that it's the wiring harness. But the audio sounds great.

One initial install issue was that the difference between 0 and 1 volume was huge, basically the radio started out at the middle of the normal volume scale rather than the bottom. Kevin @ Toytec talked to the IA guys over the phone and fixed that by tweaking the baseline audio volume for each of the various input methods.

I have a big focus on GPS nav + tracking offroad via BackCountry Navigator / Gaia GPS, but since the head unit / OS is the same as what the Jeep guys have I'll guess that many of them have already explored these possibilities. So it's time to hop over to the Jeep side and get to reading. I'd also like to figure out how to connect the FJ's backup camera to the head unit, I know the head unit has the inputs so now it's just finding where to disconnect it from the rearview mirror.

As the IA guys provide additional wiring harnesses or updates for our unit related to the factory JBL setup, I'll keep this thread updated with my experiences. This is a great product and I've been waiting for a while for something like it to come along. I'm very happy to help make it a plug-and-play install for the FJ JBL. :D

James

p.s. obligatory offroading pic:

Image

InsaneAudioSupport
Posts: 426
Joined: Mon Sep 01, 2014 1:09 pm

Re: FJ1001 - The JBL Install

Post by InsaneAudioSupport » Thu Mar 10, 2016 2:45 pm

Hey there, Cheeseburgers in Paradise! Thanks for the good vibes!

For others reading this --- just as a FYI --- Insane Audio's FJ1001 isn't technically available for FJ Cruisers with the JBL sound system but will be soon. This individual is one of our test pilots! Currently the FJ1001 works with ALL other factory options for ALL other FJ Cruisers including the base system and the FJAMMER system.

Back to you, Mr. Margaritaville --

Firstly, please know that none of our products currently support Sirius Satelite radio. If this is something that is important to you, please see the following thread for options -- http://insanejeepaudio.com/forum/viewtopic.php?f=6&t=10. Also, it's worth setting expectations that we most likely won't be able to give you a plug and play option for your factory USB plug. You may need to hack some wires if that's something that you're passionate about, however, you can certainly use the USB cable that we provide which is designed to wire straight to the glove box.

Your fader problem is definitely a challenge and we need to resolve that before we "officially" release the FJ1001 to JBL equipped FJ's. Our guys are working on that right now! It is most likely going to be a change to the code in your CANBUS module (the little black box thingy on your wiring harness). We also have to cleanup that wiring harness in general based on the info we just got back from our friends over at Toytec.

Nice rig, by the way! How about some cool pics of the interior showing Insane NavEngine rendering some cool Colorado topography while you are out on the trail!

On that topic, please note that Insane NavEngine will fully support changes in latitude but will not be able to render changes in attitude. :)

InsaneAudioSupport
Posts: 426
Joined: Mon Sep 01, 2014 1:09 pm

Re: FJ1001 - The JBL Install

Post by InsaneAudioSupport » Thu Mar 10, 2016 2:46 pm

One more thing. All FJ Peeps will want to check this out. It's for our JK radio but 99% of it is relevant -- http://www.insanejeepaudio.com/IA_JK100 ... urrent.pdf

(it's also installed on your unit and is an icon right on your home screen)

jimmy-buffett
Posts: 3
Joined: Wed Mar 09, 2016 8:56 pm

Re: FJ1001 - The JBL Install

Post by jimmy-buffett » Fri Mar 11, 2016 9:17 am

InsaneAudioSupport wrote:Firstly, please know that none of our products currently support Sirius Satelite radio. If this is something that is important to you, please see the following thread for options -- http://insanejeepaudio.com/forum/viewtopic.php?f=6&t=10.
Not a problem for me, so we're good. 99% of what I listen to while driving around is podcasts, so as long as I've got streaming bluetooth I'm set.
InsaneAudioSupport wrote:Also, it's worth setting expectations that we most likely won't be able to give you a plug and play option for your factory USB plug. You may need to hack some wires if that's something that you're passionate about, however, you can certainly use the USB cable that we provide which is designed to wire straight to the glove box.
I'm guessing that the factory USB plug is one of the two plugs not currently in use from the FJ's side. I don't use it as an audio input, but I do occasionally use it for charging. If I'm very lucky, there's another connector on the back where I can just plug in the USB directly to the FJ1001. Otherwise, I'll probably just leave it alone. A more interested future customer than me can cut/splice the wires and get that plug back to working.
InsaneAudioSupport wrote:Your fader problem is definitely a challenge and we need to resolve that before we "officially" release the FJ1001 to JBL equipped FJ's. Our guys are working on that right now! It is most likely going to be a change to the code in your CANBUS module (the little black box thingy on your wiring harness). We also have to cleanup that wiring harness in general based on the info we just got back from our friends over at Toytec.
This is the one that stumped Kevin and I as well, but as long as I'm getting sound/subwoofer from the back I'm good for now. Cleaning up the harness, also a good thing. This direct interaction and support in the forums is a big part of why I'm happy to be an FJ1001 owner!
InsaneAudioSupport wrote:Nice rig, by the way! How about some cool pics of the interior showing Insane NavEngine rendering some cool Colorado topography while you are out on the trail!
Will do! Still pretty snowy here but I'll see if I can get some good screen caps while driving up to ski.

jimmy-buffett
Posts: 3
Joined: Wed Mar 09, 2016 8:56 pm

Re: FJ1001 - The JBL Install

Post by jimmy-buffett » Tue May 24, 2016 7:29 am

5/24 update:

I received the new JBL-specific wiring harness from IA last night, it's much cleaner than the original harness (2 fewer plugs and minus another antenna connector). Installed with no issues! Needless to say, the wiring behind the radio was getting a little crowded :D . My main remaining issue is that the front/rear fade still doesn't work, per IA that's a canbus programming issue that they're working on. Since I don't tweak the fader, that's not a problem for me.

Did a trail run with our local FJ club last weekend, and used the head unit to download offline maps while running Gaia GPS. The setup worked great, even if I did accidentally take a wrong turn :lol:

Since I've had more chances to use this head unit, I'm very pleased with it.

Post Reply